NagForReview Makes AppBar Disappear, Does Not Popup

Feb 24, 2012 at 3:41 PM

I've used NagForReview successfully in other apps after realizing that it needed to be used on a page rather than in App.xaml.cs, but in another app I'm working on, when the code is hit and the condition matches for the method to show the popup (every 2 run of app), the Application Bar disappears and the popup also does not get displayed.

Any ideas what might be causing this?

Coordinator
Feb 24, 2012 at 6:12 PM

Do you get an exception ? Can you show the code (snippet) that shows the NagForReview being executed ? Did you create/specify a style for the NagForReview control ?

Feb 24, 2012 at 7:39 PM

Forgot to create & specify the style. I knew I was forgetting something - thanks and sorry for bothering you here over a trivial oversight (my words). :)

Coordinator
Feb 24, 2012 at 8:37 PM

No problem, glad i could help.

Jun 7, 2012 at 11:49 PM

I am having exactly the same problem.

I have followed the instructions:

1. Added the Resource Dictionary (I even tried adding that into the MainPage.xaml Resources section)

2. Set Build Action to Page

3. Call in the MainPage Constructor, after InitializeComponent():            

NagForReview.Check(NorthernLights.Controls.NagForReview.NagType.AfterXDays | NorthernLights.Controls.NagForReview.NagType.AfterXTimes, 3, 1);

It should be displayed every time (for debugging purposes), but it doesn't.

 

PS: Thanks for this great library.

Coordinator
Aug 10, 2012 at 2:00 AM

Sorry for the late response. I assume you already switch to something else or do you still need help with solving this issue ? You could download the source code and set a breakpoint in the Check() method to see if it is hit and how it is being handled.